About the dashboard

The dashboard uses real time data to tell you if ABRS online is functioning normally or experiencing issues. If there has been an outage or a change in the operational status and if after fifteen minutes your experience is not reflected contact on:

- 13 62 50 if calling from within Australia, or

- +61 2 62163440 if calling from overseas.

For details of upcoming maintenance events, visit the systems maintenance page.

Current system status

ABRS Online director ID Service Degradation
Incident Report for ABRS online
Resolved
This incident has been resolved.
Posted Nov 01, 2023 - 14:05 AEDT
Investigating
ABRS is currently investigating an issue with the ABRS online director ID service. After submission of application if you receive an error please do not reapply for your director ID. If you prefer to apply over the phone or need assistance please contact 13 62 50. Applications can also be completed using the paper form available here.
https://www.abrs.gov.au/director-identification-number/apply-director-identification-number
Posted Oct 27, 2023 - 10:15 AEDT