About the dashboard

The dashboard uses real time data to tell you if ABRS online is functioning normally or experiencing issues. If there has been an outage or a change in the operational status and if after fifteen minutes your experience is not reflected contact on:

- 13 62 50 if calling from within Australia, or

- +61 2 62163440 if calling from overseas.

For details of upcoming maintenance events, visit the systems maintenance page.

Current system status

Intermittent issues at login
Incident Report for ABRS online
Resolved
This incident has been resolved.
Posted Nov 24, 2023 - 08:57 AEDT
Investigating
We are aware of intermittent errors when using myGovID to login to ABRS Online. We are investigating this as a priority.
Posted Nov 23, 2023 - 18:17 AEDT