About the dashboard

The dashboard uses real time data to tell you if ABRS online is functioning normally or experiencing issues. If there has been an outage or a change in the operational status and if after fifteen minutes your experience is not reflected contact on:

- 13 62 50 if calling from within Australia, or

- +61 2 62163440 if calling from overseas.

For details of upcoming maintenance events, visit the systems maintenance page.

Current system status

Unplanned outage
Incident Report for ABRS online
Resolved
This incident has been resolved.
Posted Nov 28, 2022 - 18:08 AEDT
Update
We are continuing to investigate this issue.
Posted Nov 28, 2022 - 18:08 AEDT
Investigating
We are currently experiencing issues with our online system and are investigating with priority. If you are attempting to access our online system and are experiencing difficulty, please try again later. Visit ABRS.gov.au for more information and service updates.
Posted Nov 28, 2022 - 12:52 AEDT
This incident affected: Apply for director ID and Manage director ID.